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Χειρισµός & Εντολές Προγράµµατος Microwind2 
 

 

1. Ξεκινώντας 
 

Για να ξεκινήσετε το πρόγραµµα MICROWIND2 από το CD, χρησιµοποιείστε την ακόλουθη διαδικασία: 

 

 Εισάγετε το συνοδευτικό CD στον οδηγό 

 Στα Windows 98/NT/XP, κάντε διπλό κλικ στο index.html 

 Κάντε κλικ στο “Download Microwind2”. Αποσυµπιέστε το αρχείο mw2.zip στον επιθυµητό 

κατάλογο. 

 Κάντε διπλό κλικ στην εικόνα του Microwind2 για να εκκινήσετε το λογισµικό. 

 

Το λογισµικό τρέχει στα λειτουργικά συστήµατα Windows 95, 98, NT και XP. 

 

 

Παράµετροι γραµµής εντολών 
 

Η γραµµή εντολών µπορεί να περιλάβει δύο παραµέτρους: 

Η Πρώτη παράµετρος είναι το αρχείο της αρχικής µάσκας που φορτώνεται στην αρχικοποίηση. 

Η ∆εύτερη παράµετρος είναι το αρχείο των κανόνων σχεδιασµού που φορτώνεται κατά την αρχικοποίηση. 

 

Για παράδειγµα, η εντολή “microwind2 test.MSK cmos018.rul” εκτελεί το MICROWIND2 µε αρχείο 

αρχικής µάσκας το “test.MSK” και αρχείο κανόνων το “cmos018.rul”. 

 

 

∆ιαµόρφωση της εικόνας του Microwind2 
 

Μπορείτε να προγραµµατίσετε το εικονίδιο (την συντόµευση που ευρίσκεται στην επιφάνεια εργασίας) 

του Microwind2 µε το πάτηµα του δεξιού κουµπιού, και µετά “properties”. Ο αρχικός στόχος δεν περιέχει 

καµιά παράµετρο. Απλά προσθέστε το αρχικό όνοµα αρχείου για το layout και το αρχικό αρχείο κανόνων 

σχεδιασµού. Στο παρακάτω παράδειγµα, το Microwind2 χρησιµοποιεί το αρχείο “TEST.MSK” και το 

αρχείο κανόνων σχεδιασµού “CMOS018.RUL” ως αρχικές παραµέτρους. 

 
Εικόνα 1: Πρόσβαση στις ιδιότητες του εικονιδίου του Microwind2 



Εγχειρίδιο Microwind Εργαστήριο Μικροηλεκτρονικής & VLSI Τμ. Ηλεκτρονικών Μηχανικών
_________________________________________________________________________________________________________________________________________________________________________________________________  

_________________________________________________________________________________________________________________________________________________________________________________________________  

2 / 25 

 

 
Εικόνα 2: ∆ιαµορφώνοντας το Microwind2 µε αρχικό όνοµα αρχείου το “test.MSK” και αρχική 

τεχνολογία τη “cmos018.RUL” 

 

 

2. Κατάλογος εντολών στο Microwind2 
 

 
 

Πληροφορίες για την έκδοση του λογισµικού και για τον τρόπο επαφής για υποστήριξη. 

 

  
 

Χρησιµοποιείστε αυτό το εικονίδιο για να τοποθετήσετε κείµενο σε ένα κουτί ή µια τοποθεσία στο σχέδιο. 

Εκείνο το κείµενο αναδεικνύει το layout και πρέπει να χρησιµοποιείται όσο το δυνατόν περισσότερο για 

κάθε σηµαντικό κόµβο όπως οι είσοδοι και οι έξοδοι. Για να προσθέσετε κείµενο σε ένα συγκεκριµένο 

µέρος, προχωρήστε ως ακολούθως: 

 

 Κάντε κλικ στο εικονίδιο 

 Ορίστε τη θέση του κειµένου µε το ποντίκι. Ένα κουτί διαλόγου εµφανίζεται 

 Εισαγάγετε το κείµενο µπροστά από το “Label name:” και πατήστε “Assign”. Το κείµενο 

τοποθετείται στο σχέδιο. 

 

Ένα κείµενο µπορεί να τροποποιηθεί ως εξής: κάντε κλικ στο εικονίδιο, κάντε κλικ µέσα στο υπάρχον 

κείµενο. Το αρχικό κείµενο εµφανίζεται. Τροποποιήστε το και κάντε κλικ στο “Assign”. Μπορείτε να 

προσθέσετε ένα ρολόι, έναν παλµό, µια πηγή τάσης VDD ή VSS στο κείµενο. 

 

 
 

Το MICROWIND2 µετατρέπει το MSK layout σε CIF χρησιµοποιώντας µια ειδική διεπαφή, η οποία 

καλείται µε “File -> Make CIF file”. Το CIF αρχείο µπορεί να εξαχθεί σε λογισµικό CAD VLSI. Ο δεξιός 

πίνακας της οθόνης (Εικόνα 3) δίνει την αντιστοιχία µεταξύ επιπέδων MICROWIND2 και επιπέδων CIF, 

τον αριθµό των κουτιών στο layout και το αντίστοιχο over-etch. Το over-etch χρησιµοποιείται για να 
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τροποποιήσει το τελικό µέγεθος των κουτιών CIF προκειµένου να χωρέσουν στους ακριβείς κανόνες 

σχεδιασµού. 

Κάντε κλικ στο “Convert to CIF” για να ξεκινήσετε τη µετατροπή. Ορισµένα µέρη του αποτελέσµατος 

εµφανίζονται στο αριστερό παράθυρο. Η κύρια µονάδα είναι το 1nm. Μπορείτε να την αλλάξετε για να 

ικανοποιηθούν οι απαιτήσεις του στοχευόµενου εργαλείου CAD. 

Για αρχείο κανόνων CMOS 0.25µm (cmos025.RUL), παρατηρείστε το over-etch που εφαρµόζεται στην 

επαφή και το via. Αυτό το over-etch είναι επιτακτικό να υπακούει στους τελικούς κανόνες σχεδιασµού, 

ενώ ικανοποιείται ο φιλικός-στο-χρήστη και ο φορητός βασιζόµενος-στο-λάµδα σχεδιασµός. 
 

 
Εικόνα 3: Η οθόνη παραγωγής του CIF 

 

Όσον αφορά στις διαχύσεις, παρατηρείστε ότι η γεννήτρια CIF παράγει ενεργές περιοχές και εµφυτεύσεις. 

Το Microwind2 χρησιµοποιεί απλή n+διάχυση και p+διάχυση, ενώ τα περισσότερα βιοµηχανικά εργαλεία 

σχεδιασµού layout χρησιµοποιούν την ιδέα της ενεργούς περιοχής περιστοιχισµένης από εµφυτεύσεις, είτε 

n+ είτε p+, όπως φαίνεται παρακάτω. 

 
Εικόνα 4: Η µετατροπή CIF παράγει ενεργές περιοχές και εµφυτεύσεις, ώστε να είναι συµβατές µε 

βιοµηχανική διεργασία 

Τμ. Ηλεκτρονικών Μηχανικών
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Αυτό σηµαίνει ότι κάθε κουτί n+ διάχυσης που σχεδιάζεται στο Microwind µετατρέπεται σε δύο κουτιά, 

ένα συνδεδεµένο µε “Active Area” (Ενεργό Περιοχή), µε ένα κωδικό όνοµα δηλωµένο στο αρχείο 

κανόνων σχεδιασµού, ένα δεύτερο κουτί συνδεδεµένο µε το “diffn”, µε ένα δοσµένο overetch. Κάθε κουτί 

p+ διάχυσης µετατρέπεται σε δύο κουτιά επίσης. Ένα είναι συνδεδεµένο µε την ίδια “Active Area”, και 

ένα δεύτερο κουτί είναι συνδεδεµένο µε το “diffp” µε ένα δοσµένο overetch. 

 

 
 

• Μετατροπή σε µονόχρωµο: το φυσικό σχέδιο (layout) σχεδιάζεται σε µαύρο και άσπρο. Αυτός ο τύπος 

σχεδιασµού είναι βολικός για την κατασκευή µονόχρωµης τεκµηρίωσης. Πατήστε “Alt”+ “Print 

Screen” για να αντιγράψετε την οθόνη στο clipboard. Μετά, ανοίξτε “Word”, κάντε κλικ “Edit-

>Paste”. Η οθόνη εισάγεται στο έγγραφο. 

• Άσπρο παρασκήνιο. Τα επίπεδα εµφανίζονται µε µια παλέτα χρωµάτων πάνω σε άσπρο παρασκήνιο. 

 

 
 

Κάντε κλικ στο εικονίδιο Copy. Μετακινήστε τον δροµέα (cursor) στο παράθυρο σχεδιασµού και 

οριοθετήστε την ενεργό περιοχή µε το ποντίκι. Ακολούθως, όλα τα γραφικά που περιλαµβάνονται σε 

αυτήν την περιοχή αντιγράφονται. Το εξωτερικό περίγραµµα των αντιγραµµένων αντικειµένων 

εµφανίζεται. Τοποθετείστε εκείνα τα αντιγραµµένα αντικείµενα στην επιθυµητή θέση µε ένα κλικ στο 

ποντίκι.  

Κάντε κλικ στο Undo για να ακυρώσετε την εντολή αντιγραφής.  

ΠΡΟΣΟΧΗ!!  Η διαδικασία της αναίρεσης στο MICROWIND λειτουργεί δυστυχώς µόνο για την 

τελευταία ενέργεια. 

 

 
 

Κάντε κλικ στο εικονίδιο Cut. Μετακινήστε τον δροµέα (cursor) στο παράθυρο σχεδιασµού και περιορίστε 

την ενεργό περιοχή µε το ποντίκι. Ακολούθως, όλα τα γραφικά που περιλαµβάνονται σε αυτή την περιοχή 

διαγράφονται. Κάντε κλικ στο Undo αν επιθυµείτε να τα επαναφέρετε πίσω στο σχέδιο. 

• Ένα επίπεδο προστατεύεται από σβήσιµο αν αφαιρέσετε το τικ στην παλέτα δύο φορές. Στην παλέτα 

ένα άδειο τετράγωνο στα δεξιά του επιπέδου υποδεικνύει ένα προστατευµένο επίπεδο. 

• Ένα επίπεδο είναι απροστάτευτο στο σβήσιµο αν επιλέξετε ξανά στην παλέτα. Ένα τικ στο τετράγωνο 

στα δεξιά του επιπέδου υποδεικνύει ένα απροστάτευτο επίπεδο. 

• Ένα κουτί µόνο µπορεί να σβηστεί µε ένα κλικ µέσα σε εκείνο το κουτί όταν η εντολή αποκοπής είναι 

ενεργή. Το κουτί τότε σβήνεται.  

 

 
 

Ο µεταγλωττιστής κελιών είναι ένα συγκεκριµένο εργαλείο σχεδιασµένο για την αυτόµατη δηµιουργία 

κελιών CMOS από µια λογική περιγραφή. Κάντε κλικ στο Compile -> Compile One Line. Το παρακάτω 

µενού εµφανίζεται (Εικόνα 5). Η αρχική εξίσωση αντιστοιχεί σε µια πύλη NOR τριών εισόδων. Αν 

απαιτείται, µπορεί κανείς να χρησιµοποιήσει το πληκτρολόγιο προκειµένου να τροποποιήσει την εξίσωση 

και τότε να κάνει κλικ στο Compile. Η πύλη µεταγλωττίζεται και το αντίστοιχο layout παράγεται. 

 

Τμ. Ηλεκτρονικών Μηχανικών
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Εικόνα 5: Το παράθυρο του µεταγλωττιστή κελιών. 

 

• Το πρώτο µέρος της σύνταξης µιας-γραµµής αντιστοιχεί στο όνοµα της εξόδου. 

• Το τελευταίο ακολουθείται από το σύµβολο “=”, από τον κατάλογο των ονοµάτων εισόδου 

διαχωρισµένα από τελεστές AND ‘&’, OR ‘|’, XOR ‘^’, NOT ‘~’, XNOR ‘~^’. Αν χρειάζεται, 

µπορούν να προστεθούν παρενθέσεις. 

• Τα ονόµατα των εισόδων και των εξόδων είναι φράσεις των 8 χαρακτήρων κατά µέγιστο. 

 

 
Πίνακας 1: Παραδείγµατα περιγραφών λογικών κελιών 

 

Τα τρανζίστορ p-καναλιού τοποθετούνται στο πάνω µέρος του δικτύου των τρανζίστορ n-καναλιού. Αν 

κάποιο layout υπάρχει ήδη κοντά σε εκείνα τα εικονίδια, η αρχή του κελιού µετακινείται προς τα δεξιά 

µέχρι να βρεθεί αρκετός ελεύθερος χώρος. Αν ο τελεστής NOT (Σύµβολο ‘~’) δεν έχει προσδιοριστεί µετά 

το σύµβολο ‘=’, ένας αντιστροφέας (INVERTER) προστίθεται στο δεξιό µέρος του µεταγλωττισµένου 

κελιού. Αυτός είναι ο λόγος για τον οποίο µια πύλη AND µεταγλωττίζεται ως µια πύλη NAND 

ακολουθούµενη από έναν αντιστροφέα. 

 

 
 

Ο µεταγλωττιστής κελιών µπορεί να χειριστεί αυτόµατα την παραγωγή φυσικού σχεδίου (layout) από ένα 

αρχέγονα-βασισµένο κείµενο περιγραφής σε VERILOG. Κάντε κλικ στο Compile -> Compile Verilog 

File. Επιλέξτε ένα αρχείο κειµένου VERILOG και κάντε κλικ στο “Generate”. Για παράδειγµα, ο 

κατάλογος του microwind2 περιέχει το αρχείο “FADD.TXT”, το οποίο αντιστοιχεί στην περιγραφή ενός 

πλήρους αθροιστή (Full Adder). 

 
Εικόνα 6: Το παράθυρο του µεταγλωττιστή VERILOG 

Τμ. Ηλεκτρονικών Μηχανικών
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Εικόνα 7: Τα αρχέγονα κελιά σε VERILOG που υποστηρίζονται από τον µεταγλωττιστή CMOS 

 

Οι κόµβοι εισόδου/εξόδου δροµολογούνται στο πάνω και στο κάτω µέρος των ενεργών µερών, µε ένα 

κανονικό διάκενο για να διευκολυνθεί η αυτόµατη δροµολόγηση καναλιών µεταξύ κελιών. Κάντε κλικ σε 

Compile -> Show grid για να υπερθέσετε το πλέγµα (grid) δροµολόγησης πάνω στο layout. Στην εικόνα 8 

παρουσιάζεται η δροµολόγηση εισόδων/εξόδων µεταξύ βασικών κελιών. Παρατηρείστε ότι η 

δροµολόγηση πραγµατοποιείται είτε στο πάνω µέρος είτε στο κάτω µέρος των ενεργών µερών. 

 
Εικόνα 8: Το πλέγµα (grid) του µεταγλωττιστή κελιών (CMOS cell Compiler)  

 

 
 

Ο ελεγκτής κανόνων σχεδιασµού (Design Rule Checker-DRC) σαρώνει όλο το σχέδιο και εντοπίζει τα 

σηµεία του φυσικού σχεδίου (layout) στα οποία παραβιάζονται βασικοί κανόνες σχεδιασµού. Κάντε κλικ 

στο παραπάνω εικονίδιο ή στο Analysis -> Design Rule Checker για να τρέξετε το DRC. Τα σφάλµατα 

επισηµαίνονται στο παράθυρο παρουσίασης, µε ένα κατάλληλο µήνυµα που περιγράφει τη φύση του 

σφάλµατος. Λεπτοµέρειες για τη θέση και τον τύπο των σφαλµάτων εµφανίζονται στην οθόνη. 

 
Εικόνα 9: Παράδειγµα σφάλµατος κανόνων σχεδιασµού 

Τμ. Ηλεκτρονικών Μηχανικών
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Το εικονίδιο “Draw Box” είναι το αρχικό εικονίδιο (που επιλέγεται ως ιδιότητα στη χρήση του ποντικιού). 

∆ηµιουργεί ένα κουτί στο επιλεγµένο επίπεδο. Το αρχικό επίπεδο είναι πολύ-πυρίτιο. Αν το εικονίδιο 

“Draw Box” δεν είναι επιλεγµένο, κάντε κλικ πάνω του. Μετά, µετακινήστε τον δροµέα στο παράθυρο 

παρουσίασης και τοποθετείστε την πρώτη ακµή του κουτιού µε το πάτηµα του ποντικιού. Κρατείστε 

πατηµένο και τραβήξτε το ποντίκι στην απέναντι ακµή του κουτιού. Ελευθερώστε το ποντίκι και δείτε πώς 

δηµιουργείται το κουτί. 

 

• Το ενεργό επίπεδο επιλέγεται στην παλέτα. 

• Το κόκκινο χρώµα υποδεικνύει το ενεργό επίπεδο. 

• Το γκρι κλειδί στα δεξιά του κουµπιού του επιπέδου προσδιορίζει ότι όλα τα κουτιά που 

χρησιµοποιούν το επίπεδο αυτό µπορούν να σβηστούν, επιµηκυνθούν, ή να αντιγραφούν. 

• Ένα κλικ στο γκρι κλειδί µετατρέπει το χρώµα του κλειδιού σε κόκκινο. Ένα κόκκινο κλειδί 

προστατεύει το επίπεδο. 

 

 
 

Η εντολή “Duplicate XY” είναι πολύ χρήσιµη για την παραγωγή µιας διάταξης πανοµοιότυπων κελιών 

όπως κελιά RAM για παράδειγµα. Κάντε κλικ στο Edit -> Duplicate XY, περιλάβετε τα στοιχεία για 

διπλασιασµό σε µια περιοχή που ορίζεται από το ποντίκι και εµφανίζεται η οθόνη που φαίνεται στην 

εικόνα 10. Τόσο στο Χ όσο και στο Υ, ο αρχικός παράγων πολλαπλασιασµού είναι x2. Μπορείτε να 

προσαρµόσετε το κενό µεταξύ των κελιών. Εξ αρχής, τα κελιά βρίσκονται σε επαφή µεταξύ τους. Τα 

επιλεγµένα κουτιά εµφανίζονται στο δεξιό παράθυρο και επίσης µε κίτρινο στο κύριο παράθυρο layout. 

 

 
Εικόνα 10: Το µενού Duplicate X, Y, χρησιµοποιείται για τη διασταύρωση metal1/metal2 

 

Η επιλογή data (Assign data, Edit Hexadecimal data, Fill Array) είναι πολύ χρήσιµη για την παραγωγή 

µασκών ROM ή διατάξεων αποκωδικοποιητών. Ένα παράδειγµα µιας διάταξης αποκωδικοποιητή δίδεται 

στην εικόνα 10. Ο προγραµµατισµός επηρεάζει το via µεταξύ metal1 και metal2, σύµφωνα µε τη λίστα 

των δεκαεξαδικών τιµών που δίδονται στη λίστα επεξεργασίας. 

Τμ. Ηλεκτρονικών Μηχανικών
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• Κάντε κλικ στα επιθυµητά δεδοµένα στην περιοχή επεξεργασίας “Edit hexadecimal data”. Οι τιµές 

πρέπει να διαχωρίζονται µε ένα κενό. 

• Κάντε κλικ στο “Fill array” για να µετατρέψετε αυτά τα δεδοµένα σε Boolean τιµές, σύµφωνα µε το 

µέγεθος της διάταξης Χ, Υ. 

• Επιλέξτε το κατάλληλο κουτί για προγραµµατισµό. Σε αυτήν την περίπτωση, το 0/1 δηµιουργεί ή όχι 

ένα via σε κάθε θέση Χ, Υ. 

• Κάντε κλικ στο “Generate”. Το ακόλουθο αποτέλεσµα εµφανίζεται. 

 

 
Εικόνα 11: Παράδειγµα διπλασιασµού ενός προτύπου µε προγραµµατιζόµενο via 

(DuplicateXYExample.MSK) 

 

 

 
 

Για να εφαρµόσετε µια περιστροφή ή αντιστροφή σε ένα µέρος του σχεδίου, κάντε κλικ στο “Edit -> Flip 

and Rotate”, και επιλέξτε την κατάλληλη εντολή Flip (Horizontal ή Vertical). Περιορίστε την ενεργό 

περιοχή των κουτιών στο layout που θα τροποποιηθεί. 

 

 

 
 

Παρέχει µια on-line βοήθεια στη χρήση του Microwind2. Περιλαµβάνει µια περίληψη των εντολών και 

µερικές λεπτοµέρειες για τους κανόνες σχεδιασµού, όπως φαίνεται στην εικόνα 12. 

 

Τμ. Ηλεκτρονικών Μηχανικών
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Εικόνα 12: Κανόνες σχεδιασµού και ηλεκτρικοί κανόνες που προτείνεται στο µενού βοήθειας 

 

 

 
 

Η εντολή “File -> Leave Microwind2” (ή CTRL+Q) στο βασικό µενού. Αν έχετε κάνει ένα σχέδιο ή αν 

έχετε τροποποιήσει κάποια δεδοµένα, θα ερωτηθείτε να το αποθηκεύσετε. Μετά την επιβεβαίωση, 

µπορείτε να επιστρέψετε στα Windows. 

 

 

 

 
 

Η γεννήτρια layout περιλαµβάνει ένα σύνολο από προκαθορισµένες µακροεντολές layout όπως κουτί, 

επαφές, συσκευές n-MOS και p-MOS, αντιστάτες, γραµµές µετάλλου, µονοπάτι µετάλλου, επαγωγό, 

δίοδο, πυκνωτή, κείµενο και I/O pads. Εκείνα τα κελιά είναι δοµηµένα σύµφωνα µε τους κανόνες 

σχεδιασµού και παραµέτρους µεγέθους χρήστη. 
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Όπως και η εντολή “Draw Box” που περιγράφηκε σε προηγούµενες σελίδες. 

 

 

 
 

Αυτή η µακροεντολή παράγει επαφές όπως polysilicon/metal, n-diffusion/metal, p-diffusion/metal και 

metal1/metal2/metal3/metal4, ή σωριασµένες επαφές που µπορούν να ληφθούν εδώ. Μπορείτε επίσης να 

κάντε κλικ στο παραπάνω εικονίδιο στην παλέτα. Πολλαπλές επαφές µπορούν να παραχθούν όταν 

εισάγετε αριθµό επαφών στο Χ και στο Υ µεγαλύτερο από ένα. 

 

 
Εικόνα 13: Το µενού επαφών 

 

 

 
 

Αυτή η µακροεντολή παράγει είτε τρανζίστορ n-καναλιού είτε p-καναλιού. Η διπλή πύλη MOS είναι 

επίσης διαθέσιµη σε ορισµένες τεχνολογίες CMOS, για τη δόµηση µνήµης EEPROM. Οι παράµετροι του 

κελιού είναι το µήκος καναλιού (αρχική τιµή δίδεται από τους κανόνες σχεδιασµού), το πλάτος του και ο 

αριθµός των πυλών. Όταν αυτές οι παράµετροι οριστούν, εµφανίζεται το περίγραµµα της συσκευής. Κάντε 

κλικ στο ποντίκι για να την τοποθετήσετε στο κατάλληλο µέρος. 
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Εικόνα 14: Το µενού παραγωγής MOS 

 

 

 
 

Αυτή η εντολή παράγει ένα τρανζίστορ σε n-well, polysilicon ή poly2, N+ ή P+ διάχυση. Η αρχική άποψη 

του τρανζίστορ είναι ένα Ζ µε τρεις µπάρες (Παράµετρος n στο µενού). Ένα εικονικό σύµβολο αντιστάτη 

µπορεί να εισαχθεί στο layout του αντιστάτη, για να βεβαιώσει το χειρισµό του φαινοµένου αντίστασης 

κατά τη διάρκεια της εξοµοίωσης. Εξ’ αρχής, ένα επίπεδο κατ’ επιλογήν που διαµορφώνεται για να 

αφαιρέσει τη salicidation
1
 προστίθεται στο layout της αντίστασης. Εξ’ αρχής, όλα τα πολυπυρίτια και οι 

διαχύσεις έχουν µια salicide επιφάνεια επιµετάλλωσης για να µειωθεί κατά ένα παράγοντα περί το 10 η 

αντίσταση του φύλλου. Η unsalicide επιλογή συνίσταται για υψηλή τιµή αντίστασης σε µικρή περιοχή. 

Τελικά, οι επαφές προστίθενται εξ’ αρχής στις εγγύς και αποµακρυσµένες άκρες της αντίστασης για να 

διευκολυνθεί η περαιτέρω διασύνδεση. 

 

 
Εικόνα 15: Το µενού γεννήτριας αντιστάσεων 

 

                                                 
1
 Σηµείωση: salicidation (self-aligned silicide) είναι µια διαδικασία στην τεχνολογία παραγωγής ολοκληρωµένων κυκλωµάτων, 

η οποία βασίζεται στη χρήση πυριτίου (silicon) και τανταλίου (tantalum) ως µείγµα µε όνοµα silicide. Η διαδικασία salicide 

χρησιµοποιείται για την κατασκευή µασκών πολυπυριτίου για τις πύλες των pΜOS και nMOS τρανζίστορ. Η τεχνική αυτή 

εξασφαλίζει πολυπυρίτιο χαµηλής σχετικά αντίστασης, καθιστώντας το κατάλληλο για διασυνδέσεις µεταξύ των τρανζίστορ, 

αντί για τη χρήση µετάλλου. Έτσι χρησιµοποιείται πολυπυρίτιο και για τις πύλες των τρανζίστορ και για τη διασύνδεση των 

πυλών τους, απλοποιώντας τις µάσκες που χρησιµοποιούνται στην παραγωγή των ολοκληρωµένων κυκλωµάτων. 
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Αυτή η εντολή παράγει µια σπείρα φτιαγµένη από επίπεδα µετάλλου ορισµένα-από-το-χρήστη. Αυτή η 

συσκευή χρησιµοποιείται για ταλαντωτές πολύ υψηλής συχνότητας. Αυτός ο αγωγός θεωρείται ως µια 

επαγωγή χάριν στο εικονικό σύµβολο επαγωγού που εισάγεται στο layout. Μια εκτίµηση της επαγωγής 

προτείνεται µε το πάτηµα του κουµπιού Update L,Q. Ο επαγωγός µπορεί να είναι ένας σωρός από 

διάφορα επίπεδα, χάριν στο µενού επιπέδων. 

 

 
Εικόνα 16: Το µενού γεννήτριας επαγωγών 

 

 

 
 

Αυτή η εντολή παράγει ένα σύνολο από παράλληλες γραµµές µε επίπεδα, πλάτος και διάκενο ορισµένα-

από-το-χρήστη. Αυτή η εντολή είναι χρήσιµη για τη δόµηση συνεζευγµένων διασυνδέσεων, ή µονοπατιών 

διαύλων που χρησιµοποιούνται στην τελική δροµολόγηση του τσιπ. 
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Εικόνα 17: Το µενού γεννήτριας διαύλων 

 

 

 
 

Αυτή η εντολή παράγει ένα µονοπάτι από διασυνδέσεις χρησιµοποιώντας ένα και µοναδικό επίπεδο. Το 

πλάτος του µονοπατιού µπορεί να αλλαχθεί, καθώς επίσης και η ευθυγράµµιση στο δίκτυο δροµολόγησης. 

Ένα σύνολο επαφών µπορεί επίσης να τοποθετηθεί και στα δύο άκρα του µονοπατιού. Αυτή η εντολή 

είναι πολύ χρήσιµη για σχεδιασµό τροφοδοσίας VDD και VSS και για διασυνδέσεις ενός επιπέδου. 

 

 

 
Εικόνα 18: Το µενού διαµόρφωσης µονοπατιών 

 

 

 
 

Είναι δυνατόν να προστεθούν διάφορα αντικείµενα όπως µονό pad (συνήθως 80x80µm), ή ακόµα και ένα 

σύνολο από pads παντού και στο layout χρησιµοποιώντας δακτυλίους τροφοδοσίας VDD και VSS. Στην 

τελευταία περίπτωση (προσθέτοντας περισσότερα από ένα pad), δώστε τον αριθµό των pads για κάθε 
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πλευρά του τσιπ και αν απαιτείται τροποποιήστε το πλάτος των γραµµών VDD και VSS, καθώς και τον 

αριθµό των ζευγών pad VDD/VSS. 

 

 

 
 

Μπορείτε να παράγετε επίσης µια σφραγίδα πόλωσης γύρω από την επαφή για τη δηµιουργία µιας 

προστασίας µε pad δίοδο για παράδειγµα. 

 

 

Make Spice File 

 

Κάντε κλικ στο File -> Make Spice File για να µεταφράσετε το σχέδιό σας σε µια περιγραφή συµβατή µε 

SPICE. Ο εξαγωγέας κυκλωµάτων που περιλαµβάνεται στο λογισµικό παράγει το ισοδύναµο 

κυκλωµατικό διάγραµµα του layout και µια netlist συµβατή µε SPICE έτοιµη για εξοµοίωση. Μπορείτε να 

επιλέξετε ένα µοντέλο που θα χρησιµοποιήσετε για την εξοµοίωση. Η επιλογή κείται µεταξύ model 1, 

model 3 και model 9. 

 

♦ Η περιγραφή SPICE περιλαµβάνει τη λίστα από τρανζίστορ n-καναλιού και p-καναλιού και το 

συσχετισµένο µε αυτά πλάτος και µήκος εξαχθέν από το layout. 

♦ Το αρχείο κειµένου επίσης αναφέρει λεπτοµερώς τα ονόµατα κόµβων, τις παρασιτικές χωρητικότητες, 

και τα µοντέλα συσκευών. 

♦ Το όνοµα αρχείου του SPICE αντιστοιχεί στο τρέχον όνοµα αρχείου µε την κατάληξη .CIR 

 

 

 
 

Ο χάρακας δίνει τις οριζόντιες και κάθετες µετρήσεις (dx και dy) µεταξύ δύο σηµείων, απευθείας στην 

οθόνη σε λάµδα (λ) και µικρά (µm). Η αλγεβρική απόσταση (d) δίδεται επίσης σε µm. Ο χάρακας απλά 

σβήνεται από την εντολή “View -> Refresh the screen” ή πατώντας <ESC>. 

 

 

 
 

Κάντε κλικ στο εικονίδιο. Η καµπύλη Id/Vd του αρχικού MOS (W=20µm, L=L minimum) εµφανίζεται. 

♦ Τα αποτελέσµατα της αλλαγής των παραµέτρων του µοντέλου µπορούν να φανούν άµεσα στην οθόνη 

µε το κλικ στα µικρά βέλη (Up/Down), τα οποία αλλάζουν τις τιµές των παραµέτρων. 

♦ Κάντε κλικ στο “Id vs Vg” για να επισηµάνετε την τάση κατωφλίου 

♦ Κάντε κλικ στο “Id(log) vs. Vg” για να δείτε τη συµπεριφορά υπό-κατωφλίου. 
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♦ Προσθέστε µετρήσεις επιλέγοντας ένα αρχείο “.MES” 

♦ Μεταβείτε από τη συσκευή NMOS στην PMOS κάνοντας κλικ στο αντίστοιχο κουµπί 

♦ Επιλέξτε ένα µέγεθος για τη συσκευή στο κατώτερο µενού λίστας 

 

 
 

Τρία µοντέλα µπορούν να χρησιµοποιηθούν: 

• MOS Model 1 (Berkeley Spice level 1) για συσκευές µακριού καναλιού. Αυτό το µοντέλο είναι 

ξεπερασµένο αλλά παραµένει ενδιαφέρον για σύγκριση µε προηγµένα µοντέλα. 

• MOS Model 3 (απλουστευµένη µορφή του Berkeley Spice level 3). Παραµένει σε χρήση για πρώτης 

τάξης εκτίµηση της απόδοσης των κυκλωµάτων. 

• BSIM4 (απλουστευµένη µορφή του Berkeley MOS BSIM4). Το µοντέρνο µοντέλο για µοντελοποίηση 

συσκευών στη βαθιά υπό-µικρόν περιοχή. 

 

 

 
 

Κάντε κλικ στο “Edit -> MOS List” για να πάρετε τη λίστα των συσκευών MOS n-καναλιού και p-

καναλιού που υπάρχουν την εκάστοτε στιγµή στο layout. Η λίστα MOS παρουσιάζεται στο παράθυρο 

πλοήγησης. Κάντε κλικ στο επιθυµητό MOS στη λίστα για να µεγεθύνετε στην αντίστοιχη τοποθεσία στο 

layout. 

 

 

 
 

Για να µετακινήσετε ένα κουτί, κάντε κλικ στο παραπάνω εικονίδιο. Χρησιµοποιώντας το ποντίκι, 

δηµιουργήστε µια περιοχή που να περικλείει το κουτί. Μετά, τραβήξτε το ποντίκι στη νέα θέση και 

απελευθερώστε το ποντίκι. Σαν αποτέλεσµα, το κουτί έχει µετακινηθεί στη νέα θέση. Επαναλάβετε το ίδιο 

προκειµένου να µετακινήσετε ένα σύνολο από κουτιά. 
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♦ Για να προστατέψετε ένα επίπεδο από το να µετακινηθεί, κάντε κλικ στο τετράγωνο της παλέτας η 

οποία βρίσκεται στη δεξιά πλευρά του επιπέδου. Αυτό θα µετακινήσει το τικ. 

♦ Για να τεντώσετε ένα κουτί, κάντε κλικ στη µία πλευρά του κουτιού που θέλετε να τεντώσετε. Το 

περίγραµµα του κουτιού εµφανίζεται. Τραβήξτε το ποντίκι στη νέα θέση και απελευθερώστε το 

ποντίκι. Το κουτί τεντώθηκε. 

 

Συµβουλή: Για να πιάσετε το επιθυµητό όριο του κουτιού, τραβήξτε µια γραµµή κάθετη στο σύνορο, 

µπαίνοντας στο κουτί 

 

 

 
 

Για να µετακινήσετε ένα κουτί λάµδα-λάµδα, κάντε κλικ στο “Edit -> Move Step by Step”. 

Χρησιµοποιώντας το ποντίκι, δηµιουργήστε µια περιοχή που να περιλαµβάνει τα κουτιά. Η επιλογή 

εµφανίζεται κίτρινη. Μετά, κάντε κλικ στο βέλος µέχρι η επιλογή να µετακινηθεί στη νέα θέση. Η τιµή 

του βήµατος µετακίνησης (σε λάµδα) δηλώνεται στη γραµµή επεξεργασίας. 

 

 
 

 

 
 

Κάντε κλικ στο “File -> New” προκειµένου να ξαναξεκινήσετε το λογισµικό µε µια άδεια οθόνη. Το 

τρέχον σχέδιο πρέπει να σωθεί πριν τη χρήση αυτής της εντολής, καθώς όλη η γραφική πληροφορία θα 

σβηστεί από τη µνήµη του υπολογιστή. ∆εν υπάρχει Undo για να αναιρέσετε την εντολή New. 

 

 

 
 

Κάντε κλικ στο παραπάνω εικονίδιο. Στη λίστα, κάντε διπλό κλικ στο αρχείο που θα φορτωθεί. Η αρχική 

επέκταση είναι “.MSK” η οποία αντιστοιχεί στα αρχεία layout. Τα αρχεία CIF (“.CIF”) µπορούν να 

φορτωθούν µε τον ίδιο τρόπο. Το κατάλληλο πρόγραµµα µετατροπής µετασχηµατίζει την είσοδο CIF σε 

µορφή MSK. 
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Η παλέτα βρίσκεται στη δεξιά πλευρά της οθόνης. Ένα µικρό τικ υποδεικνύει το τρέχον επίπεδο. Το 

τρέχον επίπεδο εξ’ αρχής είναι το πολυπυρίτιο (polysilicon-PO). Η λίστα των επιπέδων παρουσιάζεται 

παρακάτω. 

 

 
 

♦ Αν αφαιρέσετε το τικ στο δεξιό µέρος του επιπέδου, το επίπεδο γυρνάει σε κατάσταση προστασίας. Οι 

εντολές Cut, Stretch, και Copy δεν µπορούν πλέον να επηρεάσουν το επίπεδο. 

♦ Χρησιµοποιήστε το “View -> Protect all” για να προστατέψετε όλα τα επίπεδα. Τα τικς σβήνονται. 

♦ Χρησιµοποιήστε το “View -> Unprotect all” για να αναιρέσετε την προστασία. Όλα τα επίπεδα 

µπορούν να επεξεργαστούν. 

 

 

 
 

Κάντε κλικ στο παραπάνω εικονίδιο για να προβείτε στην εξοµοίωση διεργασίας. Μια γραµµή 

χειριζόµενη-µε-ποντίκι παρέχεται και ενσωµατώνει την τοµή. Η παρακάτω οθόνη εµφανίζεται. Τα βέλη 

µπορούν να χρησιµοποιηθούν για να µετακινηθεί η τοµή προς τα δεξιά ή προς τα αριστερά του άξονα Χ, 

και µπροστά ή πίσω στον Υ άξονα. Μεγεθύνσεις ή σµικρύνσεις είναι διαθέσιµες. Αφαιρέστε τα ονόµατα 

επιπέδων, αφαιρώντας το τικ µπροστά από το “Layer infos”. 
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Κάντε κλικ στο “Simulation -> Process Steps in 3D”. Κάντε κλικ στο “Next step” για να 

παρακολουθήσετε τον τρόπο µε τον οποίο το τρέχον επεξεργαζόµενο layout στην οθόνη, θα 

παρασκευαστεί χρησιµοποιώντας την επιλεγµένη τεχνολογία. Χρησιµοποιήστε το βέλος για να ολισθήσετε 

το εµφανιζόµενο µέρος. Μεγεθύνσεις και σµικρύνσεις είναι διαθέσιµες. 

 

 
 

 

 
 

Κάντε κλικ στο “View -> Protect All” για να προστατέψετε όλα τα επίπεδα από σκοπό επεξεργασίας. Όλα 

τα τικς στην παλέτα θα αφαιρεθούν. 
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Κάντε κλικ στο “File -> Print Layout” για να µεταφέρετε τα γραφικά περιεχόµενα της οθόνης στον 

εκτυπωτή. Εναλλακτικά, µπορείτε να κάνετε ένα αντίγραφο στο παράθυρο στο clipboard προκειµένου να 

εισάγετε την οθόνη στον επιθυµητό επεξεργαστή κειµένου πατώντας <Alt> + <Print Screen>. Στον 

επεξεργαστή κειµένου ή στον επεξεργαστή γραφικών, απλά κάντε κλικ στο “Edit -> Paste”. Συνιστούµε 

να αλλάξετε σε µονόχρωµη παρουσίαση πρώτα καλώντας τη λειτουργία “File -> Colors -> Switch to 

Monochrom”. Σε αυτήν την περίπτωση το layout θα ζωγραφιστεί σε ένα άσπρο παρασκήνιο 

χρησιµοποιώντας επίπεδα του γκρι και διαγραµµίσεις. 

 

 

 
 

Για να εφαρµόσετε την περιστροφή σε ένα κοµµάτι του σχεδίου, κάντε κλικ στο “Edit -> Rotate”. 

Περιορίστε την ενεργό περιοχή των κουτιών στο layout έτσι ώστε να µπορεί να τροποποιηθεί 

χρησιµοποιώντας το ποντίκι. 

 

 

 
 

Κάντε κλικ στο “File -> Save” για να σώσετε το layout µε το τρέχον όνοµά του. Το αρχικό όνοµα είναι 

“EXAMPLE.MSK”. 

 

 

 
 

Ένα νέο παράθυρο εµφανίζεται, στο οποίο µπορείτε να εισάγετε το όνοµα του σχεδίου. Χρησιµοποιήστε 

το πληκτρολόγιο και γράψτε το επιθυµητό όνοµα αρχείου. Πατήστε “Save”. Το σχέδιο καταχωρείται µε το 

επίθεµα .MSK. 

 

 

 
 

Ο πιο βολικός τρόπος για να βρείτε ένα κείµενο στο layout είναι καλώντας το “Edit -> Search Text”. Η 

λίστα των ετικετών κειµένου εµφανίζεται στο µενού πλοήγησης. Αν κάντε κλικ στο επιθυµητό κείµενο, η 

οθόνη ξανασχεδιάζεται έτσι ώστε η επόµενη ετικέτα να είναι στο κέντρο του παραθύρου, µε δύο γραµµές 

να σχεδιάζουν ένα σταυρό στη θέση του κειµένου. Οι ιδιότητες εµφανίζονται στο µενού πλοήγησης. 

♦ Κάντε κλικ στο “Hide” για να κλείσετε το παράθυρο πλοήγησης. 

♦ Κάντε κλικ στο “Extract” για να προσθέσετε τις ηλεκτρικές ιδιότητες του επιλεγµένου κειµένου αν το 

layout δεν έχει εξαχθεί προηγουµένως. 

♦ Στην περίπτωση µιας πολύ µεγάλης λίστας κειµένου, επιλέξτε το πρώτο γράµµα του κειµένου ανά 

χείρας, πατήστε αυτό το γράµµα στο πληκτρολόγιο. Αυτό θα έχει αυτόµατα αποτέλεσµα και θα 

ερευνήσει αλφαβητικά και ο επιλογέας θα µετακινηθεί στην πρώτη ετικέτα που αρχίζει από το 

επιλεγµένο γράµµα. 
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Κάντε κλικ στο “File -> Select Foundry”. Η λίστα µε τις διαθέσιµες διεργασίες εµφανίζεται. Το αρχικό 

αρχείο κανόνων σχεδιασµού είναι γραµµένο µε έντονους χαρακτήρες. ∆ιάφορες τεχνολογίες είναι 

διαθέσιµες από 1.2 έως και 0.12 µm. Κάντε κλικ στο όνοµα αρχείου κανόνων και το λογισµικό 

αναδιαµορφώνει τον εαυτό του προκειµένου να προσαρµοστεί στη νέα διεργασία. 

 

 

 
 

♦ Η αρχική εξαγωγή περιλαµβάνει την αφαίρεση πλεοναζόντων κουτιών (Purge) και την αφαίρεση των 

επικαλύψεων (Merge). Η γρήγορη εξαγωγή δεν χειρίζεται λειτουργίες Purge ή Merge. 

♦ Το επίπεδο MOS µπορεί να επιλεχθεί µεταξύ επιπέδου 1, 3 και 9. ∆είτε το κεφάλαιο 2 για 

περισσότερες λεπτοµέρειες για τα µοντέλα. 

♦ Άλλες επιλογές αφορούν στον υπολογισµό της πλευρικής (lateral) χωρητικότητας και της 

ωρητικότητας κάθετου crosstalk. 

 

 

 
 

Η εξοµοίωση γίνεται άµεσα στο layout µε µια παλέτα χρωµάτων. Τα πιο ενδιαφέροντα αρχεία layout που 

µπορούν να εξοµοιωθούν σε αυτή τη διαµόρφωση είναι τα αναλογικά τµήµατα όπως ο DAC. 

 

 
 

Κατά τη διάρκεια του ανοιγοκλείµατος, οι συσκευές MOS του αντιστροφέα συµπεριφέρονται εναλλακτικά 

ως κλειστοί και ανοικτοί διακόπτες, όπως παρουσιάστηκε προηγουµένως. Σε µια πρώτης τάξης 

προσέγγιση, το ισοδύναµο µοντέλο του διακόπτη είναι µια αντίσταση. Στην παρουσίαση της εικόνας 4-51, 

παρέχεται το γράφηµα του σηµείου λειτουργίας στις χαρακτηριστικές Id/Vd, και για τις nMOS και για τις 

pMOS συσκευές. Έτσι, η αντίσταση δεν είναι µια απλή συνάρτηση, αλλά περισσότερο µια 

µεταβαλλόµενη αντίσταση µεταξύ συγκεκριµένων τιµών. 
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Η εικόνα 4-51 έχει ληφθεί χρησιµοποιώντας µια συγκεκριµένη λειτουργία εξοµοίωσης που λέγεται 

Simulation on Layout στο µενού εξοµοίωσης. Οι χαρακτηριστικές I/V των επιλεγµένων συσκευών 

ενηµερώνονται κατά τη διάρκεια της εξοµοίωσης για να εντοπίσουν το σηµείο λειτουργίας. 

Κατά τη διάρκεια της αναλογικής εξοµοίωσης, η τάση κόµβου υπερθέτεται στο layout και εµφανίζεται µε 

µια παλέτα χρωµάτων: 

 

 
Εικόνα 4-51: Οι συσκευές nMOS και pMOS κατά τη διάρκεια του ανοιγοκλείµατος (Inv.MSK) 

 

 

 
 

Το παραπάνω εικονίδιο ή η εντολή “Simulate -> Start Simulation” µπορεί να δώσει πρόσβαση στην 

αυτόµατη εξαγωγή και την αναλογική εξοµοίωση του layout. 

 

• Κάντε κλικ στο “Voltage vs Time” για να πάρετε τη µεταβατική ανάλυση όλων των ορατών σηµάτων. 

Η καθυστέρηση µεταξύ του επιλεγµένου κόµβου εκκίνησης και του επιλεγµένου κόµβου τερµατισµού 

υπολογίζεται στο VDD/2. Μπορείτε να αλλάξετε τον επιλεγµένο κόµβο εκκίνησης στη λίστα κόµβων, 

στο δεξιό πάνω µενού του παραθύρου. Μπορείτε να κάνετε το ίδιο για τον επιλεγµένο κόµβο 

τερµατισµού. 

• Κάντε κλικ στο “Voltage and Currents” ώστε να εµφανιστούν οι καµπύλες τάσης στο κατώτερο 

παράθυρο, και τα VDD, VSS και τα επιθυµητά ρεύµατα MOS εµφανίζονται στο ανώτερο παράθυρο. Σε 

αυτή τη διαµόρφωση, η καταναλισκόµενη ισχύς στην εξοµοίωση επιδεικνύεται επίσης. 

• Κάντε κλικ στο “Voltage vs Voltage” για να πάρετε χαρακτηριστικές µεταφοράς µεταξύ του 

επιλεγµένου κόµβου στον Χ άξονα και του αντίστοιχου στον Υ άξονα. Αρχικά ο κόµβος εκκίνησης 

είναι το πρώτο ρολόι ή παλµός στη λίστα κόµβων, και ο κόµβος τερµατισµού είναι ο πρώτος 

µεταβαλλόµενος κόµβος. Αυτή η διαµόρφωση είναι χρήσιµη για τον υπολογισµό των χαρακτηριστικών 

Αντιστροφέα (σηµείο µετάβασης), τη DC απόκριση του τελεστικού ενισχυτή, ή για το σκανδαλισµό 

Schmitt για να φανεί το φαινόµενο υστέρησης. Η πρώτη εξοµοίωση υπολογίζει την τιµή του κόµβου 

τερµατισµού και µεταβολή του κόµβου εκκίνησης από 0 σε VDD. Αυτό το γνώρισµα είναι ενδιαφέρον 

για κύκλωµα µε φαινόµενα µνήµης (Schmitt trigger). Σηµειώστε ότι οι καµπύλες µπορεί να µην είναι 

ακριβώς οι ίδιες. Μπορείτε να αυξήσετε την ακρίβεια µειώνοντας το βήµα υπολογισµού “Precision”, 

που παρέχεται στο µενού και εκφράζεται σε mV. 

 

 

ΣΗΜΕΙΩΣΗ: Μπορείτε να τροποποιήσετε το ελάχιστο βήµα εξοµοίωσης ∆t, αλλά µπορεί να είναι 

επικίνδυνο. Αν αυξήσετε το ∆t η ταχύτητα εξοµοίωσης βελτιώνεται αλλά το αριθµητικό σφάλµα µπορεί 
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να οδηγήσει σε ασταθείς εξοµοιώσεις. Αν µειώσετε το ∆t, η ταχύτητα εξοµοίωσης µειώνεται επίσης, αλλά 
η αριθµητική ακρίβεια βελτιώνεται. Το ρίσκο της υπολογιστικής απόκλισης µειώνεται. 

 

 

 
 

Τα εικονίδια εξοµοίωσης προσθέτουν ιδιότητες στους κόµβους. Ιδιότητες εφαρµόζονται στους 

ηλεκτρικούς κόµβους του κυκλώµατος προκειµένου να εξυπηρετήσουν ως οδηγοί εξοµοίωσης. Πρέπει να 

προσδιορίσετε ποιος κόµβος ανατίθεται σε ποια τάση πριν ξεκινήσετε την αναλογική εξοµοίωση. 

 

 
 

VDD & VSS. Ο κόµβος αποκτά τάση τροφοδοσίας µε το εικονίδιο Vdd και τίθεται στα 0V µε το εικονίδιο 

Vss. 

 

CLOCK. Όταν ένας κόµβος γίνεται ρολόι, οι παράµετροι του τελευταίου διαιρούνται ως ακολούθως: 

χρόνος ανόδου, επίπεδο ένα, χρόνος καθόδου, επίπεδο µηδέν. Όλες οι τιµές εκφράζονται σε nano-seconds 

(ns). Αν ζητήσετε ένα δεύτερο ρολόι, η περίοδος θα πολλαπλασιαστεί επί δύο. 

♦ Μπορείτε να ανταλλάξετε το επίπεδο 0 µε το επίπεδο 1 εισάγοντας µια νέα τιµή µε το πληκτρολόγιο. 

♦ Για να παράγετε ένα ρολόι που ξεκινά από VDD αντί για VSS, κάντε κλικ στο “Invert L/H”. 

♦ Χρησιµοποιήστε το “Period * 2” για να πολλαπλασιάσετε την περίοδο του ρολογιού επί δύο. 

♦ Χρησιµοποιήστε το “Period * 2” για να διαιρέσετε την περίοδο διά του δύο. 

 

PULSE. Ο παλµός ανοιγοκλείνει µεταξύ “Level 0” (0 εξ’ αρχής) και “Level 1” (VDD εξ’ αρχής) ανάλογα 

µε τον οριζόµενο-από-το-χρήστη χρονο-πίνακα. 

♦ Εισάγετε τη φράση «0101100» και πατήστε “Insert”. Ο χρονο-πίνακας ενηµερώνεται 

♦ Κάντε κλικ στο “Erase”: όλες οι γραµµές που βρίσκονται µετά το επιλεγµένο στοιχείο του χρονο-

πίνακα σβήνονται. 

 

SINUS. Οι παράµετροι της ηµιτονοειδούς κυµατοµορφής είναι το πλάτος, το offset, η συχνότητα και η 

φάση. 

 

VISIBLE NODE. Κάντε κλικ στο “µάτι” και κάντε κλικ στο υπάρχον κείµενο στο layout για να παράγετε 

χρονογράµµατα του κόµβου. Αρχικά, όλοι οι κόµβοι είναι ορατοί, αλλά τα ρολόγια και οι κόµβοι 

διέγερσης γίνονται ορατοί ακολούθως. 

 

 

 
 

Η εντολή “File -> Statistics” παρέχει κάποια πληροφορία για την τρέχουσα τεχνολογία, το ποσοστό της 

µνήµης που χρησιµοποιείται από το layout και το µέγεθος του layout συν τα λεπτοµερή περιεχόµενά του. 
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Αν το layout έχει εξαχθεί από πριν ή αν κάνετε κλικ στο “extract now”, ο αριθµός των συσκευών και των 

κόµβων θα ενηµερωθεί. 

 

 
 

 

 
 

Η εντολή Undo (Edit -> Undo) είναι χρήσιµη ώστε να µη ληφθεί υπ’ όψιν η τελευταία εντολή 

επεξεργασίας. Είναι δυνατόν να κάνετε Undo στις εντολές Cut, Paste, Copy, Move, Stretch, Edit και 

Compile. 

 

 

 
 

Κάντε κλικ στο “View -> Unprotect All” για να επιλέξετε όλα τα επίπεδα για λόγους επεξεργασίας. Όλα 

τα τικς στην παλέτα διεγείρονται. 

 

 

 
 

Κάντε κλικ στο “View -> Unselect All” (ή στο <ESC>) για να αποεπιλέξετε το layout. Αυτή η εντολή 

είναι χρήσιµη για το σχεδιασµό του layout µε τα αρχικά χρώµατα µετά από εντολές όπως η View 

Interconnect ή η View Node, οι οποίες επισηµαίνουν ένα και µόνο κόµβο. 

 

 

 
 

Κάντε κλικ στο “View -> View All” για να χωρέσετε την εικόνα µε όλα τα τρέχοντα γραφικά στοιχεία 

στην οθόνη. 
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Κάντε κλικ στο παραπάνω εικονίδιο ή στο “View -> View Node”. Μετά, κάντε κλικ στο επιθυµητό κουτί 

στο layout. Μετά από την ολοκλήρωση µιας διαδικασίας εξαγωγής, θα δείτε όλα τα κουτιά που είναι 

συνδεδεµένα σε αυτόν τον κόµβο. Στην περίπτωση ενός µεγάλου layout, η εντολή µπορεί να πάρει χρόνο. 

Η συσχετιζόµενη παρασιτική χωρητικότητα, η λίστα των ετικετών κειµένου που έχει προστεθεί στα 

επιλεγµένα κουτιά, και οι ιδιότητες κόµβου θα φανούν επίσης σε ένα ξεχωριστό παράθυρο πλοήγησης. 

Κάντε κλικ στο “Unselect”, “Hide”, <Escape> “View -> Unselect All” για να αποεπιλέξετε το layout. 

 

 
 

 

 
 

Η εντολή “View -> View Interconnect” εκτελεί µια ηλεκτρική εξαγωγή των κουτιών µετάλλου και 

πολυπυριτίου που είναι συνδεδεµένα µε το επιθυµητό σηµείο. Σε σύγκριση µε το View Node, αυτή η 

εντολή δουλεύει ταχύτερα αλλά δεν λαµβάνει υπ’ όψιν διαχυµένα επίπεδα που µπορούν να προεκτείνουν 

τον δίκτυο κόµβων διασύνδεσης. Η εντολή δίνει µια λίστα συνδεδεµένων ετικετών κειµένου. 

Κάντε κλικ στο <Escape> ή στο View -> Unselect All για να αποεπιλέξετε το layout. 
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Τα παραπάνω εικονίδια εκτελούν Μεγέθυνση ή Σµίκρυνση. Όταν µεγεθύνετε, η περιοχή που 

προσδιορίστηκε από το ποντίκι θα µεγαλώσει για να χωρέσει στο παράθυρο παρουσίασης. Όταν 

σµικρύνετε, η περιοχή που προσδιορίστηκε µε το ποντίκι θα περιέχει το παράθυρο παρουσίασης. 

 

♦ Αν κάνετε κλικ µία φορά, µια µεγέθυνση θα εκτελεστεί στην επιθυµητή περιοχή. 

♦ Πατήστε CTRL+A για να κάνετε “View All”, και CTRL+o για να κάνετε σµίκρυνση. 

 

 

 

 

 

Βιβλιογραφία 

 

A book on deep submicron CMOS design using Microwind (Appendix B) 

by Etienne Sicard and Sonia Bendhia, http://intrage.insa-toulouse.fr/~etienne/microwind/book.html 
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