
AIM  

The aim of the Finite Element Method - FEM, Lab session is to provide to the attendants the 

ability of understanding and implementing simulations of laser mater interaction problems.

1. LS-DYNA  

LS-DYNA from Livermore Software Technology Corporation (LSTC), is a highly advanced 

general purpose nonlinear finite element program that is capable of simulating complex real-

world problems. The distributed and shared memory solver provides very short turnaround 

times on desktop computers and clusters operated using Linux, Windows and UNIX.  

LS-DYNA is suitable to investigate phenomena involving large deformations, sophisticated 

material models and complex contact conditions for structural dynamic problems. LS-DYNA 

allows switching between explicit and different implicit time stepping schemes. Disparate 

disciplines, such as coupled thermal analyses, Computational Fluid Dynamics (CFD), fluid-

structure interaction, Smooth Particle Hydrodynamics (SPH), Element Free Galerkin (EFG), 

Corpuscular Method (CPM), Discrete Element Method (DEM) and the Boundary Element 

Method (BEM) can be combined with structural dynamics.  For pre- and post-processing, LS-

DYNA comes with the LS-PrePost tool. LS-PrePost can be utilized to generate inputs and 

visualize numerical results. 

1.1 Keyword format input files  

An LS-DYNA input file is a text-file in so called Keyword format usually with a *.k, *.key or 

*.dyn suffix, e.g. laser.k. A finite element model in LS-DYNA is built up by different keywords, 

which is defined for all ingoing definitions and parameters in a model (e.g. *PART, *NODE). A 

short overview of the basic structure of such an input file for a basic 1 element finite element 

model is provided. 

 



Consider a cube consisting of one element with eight node points as shown in Figure 1.1.

 

Figure 1.1 Cube consisting of one element with eight node points 

The *PART keyword is used to begin the definition of the finite element model. The keyword 

*PART contains data that points to other attributes of this part, e.g. material properties. 

Keywords for these other attributes, in turn, point elsewhere to additional attribute definitions. 

The organization of the keyword input for the cube looks like this: 

 

A brief description follows: 

*PART: We have one part with identification pid=1. This part has attributes identified by section 

identification secid=1 and material identification mid=1. 



*SECTION_SOLID: Parts definitions that reference secid=1 are defined as constant stress 8 

node brick elements (elform=1). 

*MAT_ELASTIC: Parts definitions that reference mid=1 are defined as an elastic material with 

 

*ELEMENT SOLID: The element with identification eid=1 are defined by nid=1 to nid=8 and 

belongs to pid=1. 

*NODE: The node identified by nid has coordinates x,y,z. 

Boundary conditions and time dependent loads are also set by keywords and are usually 

applied on nodes, elements, segments or parts. Set definitions are often used to define groups 

of these entities. Since all loads are time dependent, curves need to be defined that states 

time vs load unit (force, pressure etc.). 

One example of defining boundary conditions and loads on the cube looks like this: 

 

About the keywords above: 

*BOUNDARY_SPC_SET: The node set with identification nsid=1 are constrained in y-

translation and x- and z-rotations. 

*SET_NODE_LIST: This keyword defines that node 1, 2, 5 and 6 belongs to node set sid=1. 

*LOAD_SEGMENT: A pressure load is applied on a segment that are defined by node 4, 8, 7 

and 3. 

*DEFINE_CURVE: The curve consists of two points that defines the time vs pressure. This 

curve with identification lcid=1 is used for the load. 



1.2 Consistent units 

On the table below are presented consistent units for using LS-DYNA. The inappropriate 

selection of consistent units is one of the most common error done by the user.

 

Table 1.1 Consistent units using LS-DYNA 

2. LS-PrePost 

LS-PrePost is an advanced pre- and post-processor designed specifically for LS-DYNA. It is 

developed for Windows, Linux and Apple and it is free to download from the web link 

http://ftp.lstc.com/anonymous/outgoing/lsprepost/4.5/. 

LS-Prepost main functions contain: 

 Full support of LS-DYNA keyword files 

 Full support of LS-DYNA result files 

 Robust handling of geometry data (new CAD engine)   

 Pre-processing (meshing, model clean-up, entity creation)    



 Post-processing (animation, fringe plotting, curve plotting)  

2.1 Input and output files

Input  

FEM:  LS-DYNA Keyword, Nastran, I-DEAS Universal, PAM-CRASH, RADIOSS, ABAQUS  

CAD:  IGES, STEP  

ASCII:  glstat, matsum, etc.  

Binary:  d3plot, binout, etc.  

Output 

FEM:  LS-DYNA Keyword, Nastran  

Image:  PNG, TIFF, BMP, GIF, JPG, PostScript  

Movie:  AVI, MPEG, Animated GIF, JPEG  

XY Data:  CRV, CSV, XML o CAD: IGES, STEP, STL  

Other:  Post.db, Project File 

2.2 Mouse and Keyboard  

Dynamic Model Operation  

Rotate:  Shift + Left-click  

Translate:  Shift + Middle-click 

Zoom:  Shift + Right-click/Scroll-wheel 

Graphics Selection  

Pick (single):  Left Click o Area (rectangle):  Left-click + Drag  

Poly (polygon):  Left-click at corners / Right-click to finish  

List Selection 

Multi-Select: Left-click + Drag / Ctrl + Left-click  

2.3 Graphical user interface  

The graphical interface of LS-PrePost is shown in Figure 2.1.  On the right hand side, you 

can see the main toolbar. When clicking on one of these, a sub-toolbar just to the left will be 

d to create/modify/delete 

entities in your model.   

In the bottom toolbar, are found the tools which are the most commonly used to determine 

how LS-PrePost should render mesh/surfaces, orient the model, etc. There are a couple of 



the drop-down menus on the top left corner that you will use more or less frequently: 

File/View/Application/Settings. The Floating Toolbar is used to toggle between different views.  

 

Figure 2.1 Graphical interface of the LS-PREPOST 

2.4 Menus  

In this section are presented the useful menus for the user, the File Menu, the Geometry Menu 

and the FEM menu. 



 

Figure 2.2 File menu 

 

Figure 2.3 Geometry menu 



 

Figure 2.4 FEM Menu 

3. Getting started 

3.1 Purpose 

The purpose of this tutorial is to get familiar with the pre- and post-processing tools in LS Pre-

Post and also the basics of the LS-DYNA solver. 

3.2 Problem Description  

Consider the deformation of a cube on the ground with an applied pressure on the top surface.  

The task is to compute the vertical displacement of the cube due to this pressure. 

 

  

Material properties  

   Density,    7850 kg/m3  

  210 GPa  

  0.3 0.3 



3.3 Data files and unit system 

The code can be found in cube_results.k  

The S2 unit system is used in this tutorial 

 

3.4 Preparation LS-PrePost  

The most common way to work with/open LS-PrePost is to have a short-cut on the desktop 

directly. This gives you control over which version of LS-PrePost you would like to use and 

you can easily update LS-PrePost separately.  

3.4.1 View settings  

In LS-PrePost, go to View > Toolbar and activate Text and Icon (Right) 

and Text and Icon (Bottom). This is done to easier navigate through the 

different toolbars.  

Check so you can see your 

Floating Toolbar in the LS-

PrePost window.  

  

  

If not, activate it by clicking on Opti > ISO View in the bottom toolbar. 



3.5 Create model  

3.5.1 Geometry and mesh  

Click Mesh > ShapeM (always use the menu on the right side, 

if nothing else is mentioned).   

 Enter the values as in the picture to create a 1000x1000x1000 

mm solid cube with two elements in the x-, y- and z-directions. 

 Set Target Name to Cube.  

 Click Create, Accept and then Done.  

Mesh in the bottom toolbar.  

   

 

 

 

 

 

 

3.5.2 Boundary conditions  

Apply boundary conditions to fix one side of the cube: 

 Click Model > CreEnt 

 In the Entity Creation box, double-click on Boundary and click Spc in the dropdown 

that appears.  

 Select Cre 

 Set shall be activated. 

 Select XOZ as Sym Plane, Y, RX and RZ will then be activated. The boundary 

conditions will then have a translational constraint in global y direction and rotational 

constraints about x- and z-axis. 

 From the ISO-views on the top of the screen, click at the one called Top. 

 
 
 
 



 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 

Check that your coordinate system looks like the one above. To show the coordinate system, 

click Opti and activate Triad.  

 
This box shows alternatives to select the nodes. Select 

Area.  

   
 

 

 Select the nodes in the yellow square by making 

a box with the mouse.   

 A node set will be created from the nodes that 

were chosen, NSID = 1 in Entity Creation indicates 

that it will get an Id = 1.  

 Click Apply, then Done in the Entity Creation 

box.  

The nodes are now constrained.  

   
   
  

 



3.5.3 Apply the load 

For loads, a curve must be defined that states the variation of the load over time. Click Model 

> Keywrd. In the dialog window that opens, there one can change between Model and All.  

Model shows the keywords that already have been created. All shows all possible keywords 

that are available in LS-DYNA.  

Select All at the top of Keyword Manager window. Double-click DEFINE > CURVE. Name the 

curve Curve  Pressure for example. All titles are optional, but it is good practice to make 

use of them to make the model clear and structured.   The points for the curve will be written 

in A1 and O1:  

 

 

 Write 0 and 0, Click Insert.  

 Then 1 and 1, Insert. 

 Finally, 1.1 and 1, Insert.  

 Click Accept  

 

It is important that the curve extends beyond the end time of the simulation. The simulation 

will have the termination time 1 s (will be set later). Therefore, the last point of 1.1 was added. 

 

 



To view the curve, Click Plot. Close the PlotWindow (X or Quit) and the *DEFINE_CURVE 

(Done) window. 

 

Now click Model > CreEnt:  

 

 In the Entity Creation box, double-click on Load and click on 

Segment in the dropdown that appears.  

 Click Cre  

 Change Type: to LOAD_SEGMENT_SET.  

 Give the load the title Pressure.  

 Click on LCID and select 1 Curve  Pressure, press Done.   

 To obtain a pressure of 10 MPa, the scale factor SF will be used.  

 Set SF to 10 (the pressure unit is MPa for the selected unit system).  

 From the selection box, Pick can be activated.  

 Click on the four segments on the top of the cube, as in the figure. If necessary, 

deactivate entities with right mouse button.   

 Click Apply, then Done   

3.5.4. Termination  

The end time for the simulation needs to be set. This keyword is almost always mandatory for 

any simulation using LS-DYNA:  

 Click Model > Keywrd.   



 Double-click CONTROL > TERMINATION  

 Set ENDTIM to 1. The simulation will then last for 1 time unit, which is second in this 

case.  

 Accept, then Done.   

3.5.5 Output  

The user must request all the data needed to post-process an analysis using LS-DYNA, before 

starting the simulation. We will create something called d3plot, which gives complete output 

states of the simulation:  

 Click Model > Keywrd.   

 Double-click DATABASE > BINARY_D3PLOT  

 Set DT to 0.1. This implies that results will be printed every 0.1 time unit. 

 Accept, then Done  

 

3.5.6 Material properties  

 To create a material card to define the material properties:  

 Click Model > Keywrd   

 Double-click MAT > 001-ELASTIC. This is an isotropic elastic materia   

 Name the material to Steel.  

 Set the material properties RO, E and PR as in the figure below (also stated in section 

1.3). 

 Click Accept, then Done.   



3.5.7 Element properties  

The element type to be used:  

 From Keyword Manager, double-click SECTION > SOLID.  

 Name the section to Cube  

 Use ELFORM = 1, which is the default element formulation. 

 Click Accept, then Done.  

 

 

Now apply the material and element properties to the part. Since the part already is created, 

one can activate Model, instead of All, in the Keyword Manager. This makes it easier to 

navigate through the list of keywords.  

 Double-click PART > PART  

 Click on the black dot next to SECID, defined entities will then be shown Select your 

newly created section (1 Cube) and Accept and then Done  

 Do the same thing for MID. Click Accept, then Done.  

The result should be as shown below.  

 

 

3.5.8 Check the model before running  

Now check for errors using the Model Check: 

 From the top menu, click Application > Model Checking > General Checking.   

 Switch to Keyword Check. The warnings and error should not exist.  

 Click Done.  



Note that even if no errors or warnings occurs, the model can still be incomplete or wrong. 

There is no way for any pre-processor to know your intended use of the model. Hence, the 

loadings and boundary conditions can only be checked if they make any sense, not if they are 

correct with respect to your load case.  

 

 

  

3.5.9 Save and run the simulation  

It is preferable to run each simulation in a separate folder, thus create one before saving if you 

have not done so, e.g. CUBE. First save the finished keyword model from LS-PrePost in the 

File > Save As > Save 

Keyword As. Use the file name cube.k, note the .k suffix.   

 
To how to run the simulation, you will be given orders from the instructor. 

  
3.5.10 Post processing  

To visualize the results, you need to open the d3plot result file. This is done by selecting 

File>Open>LS DYNA Binary Plot. Once Binart Plot is opened, the animate toolbar is the tool 



that enables you to step through the different states of the simulation. Hold the mouse over 

the different buttons, a text box will pop up and show information about the different 

possibilities using the animator toolbar. Play around with the buttons to see what happens. 

Note that the deformations are very small, therefore you will probably not notice that anything 

happens with the cube.   

 

To easier see what happens, you can scale up the deformations:  

 Click Settings > Post Settings in the top menu.  

 Select Displacement Scale Factor, write 5000 as the factor. X, 

Y and Z shall be activated, which implies that the displacements 

will be scaled in all directions.  

 Click Apply, then Done.  

Play around with the animate toolbar again and see how the cube 

deforms.  

  
  

   
    

  
  



Then plot the deformation history as a curve: 

 Click Post > History.  

 In the History Box, select Nodal > Y-displacement.

 Select a 

node on the top 

of the box. 

 Click Plot.  

 

 

 

 

 

 

 

In the Plot Window, Y-displacement vs Time are stated. Zoom by pressing Ctrl and make 

a box with the mouse. A right-click will reset the window to original. Zoom in on the curve 

around Time=1, click on the final state.  

Note that the Y-displacement is -0.0476 mm.  

  



 
 

When you click on the curve, information about the picked point will be stated in the Message 

box, which is located at the bottom of the LS-PrePost window. If you double-click in this box, 

a bigger box will pop up.  

 

Close the Message box and Plot Window.  

 

  
Now, click Post > FriComp> Ndv > y-displacement. Use the Animate toolbar and go to the 

last state. The values in the Fringe Level shows that the maximum y displacement is -4.761e-

02 mm. 

 
 
 
 
 
 



 

 
 

 

3.5.11 Analytical solution  

The analytical solution of the vertical displacement due to a 10 MPa pressure load is derived 
 

 
The simulation result should be nearly identical to the analytical solution.  

4. Exercises  

There are several possibilities to try out different features in LS-DYNA with this simple model. 
What happens if you change:   

 material?  



boundary conditions? 
 element formulations?  
 load level?  
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